• 欢迎访问,推荐使用最新版火狐浏览器和Chrome浏览器访问本网站
  • 如果您觉得本站非常有看点,那么赶紧使用Ctrl+D 收藏吧

PhpStorm 中配置修改 PHP 语言版本为7.3

技术百科 码拜 4天前 20次浏览 0个评论

由于PHP7相对PHP5版本性能有极大提升,所以打算将网站更新到支持PHP7,为用户带来最佳体验。于是安装了最新版 PhpStorm-2019.2.1.exe,但是PhpStorm 中默认的 PHP 语言的版本是 PHP 5.6 ,PhpStorm 会以该默认 PHP 版本对编辑器中打开的文件进行自动校验。

PhpStorm 中配置修改 PHP 语言版本为7.3

比如,我们在 PHP 项目文件中,使用了 PHP 7.0 的新特性(如 null 合并运算符 ??),那么,由于 PhpStorm 校验文件时无法识别该新特性,就会在对应位置显示一个警告标识(红色波浪线)。

虽然,这并不会对我们使用 PhpStorm 产生大的影响,但对于强迫症来说,这种红色警示让人浑身不舒服。

解决方法
修改 PhpStorm 的配置,将 PHP 语言的版本调整为 PHP 7.3 或以上版本 (目前最高版本已经 7.4) 。

点击菜单栏 File → Settings → Languages & Frameworks → PHP,将 PHP language level 下拉列表处的值修改为 7.3 ,点击 OK 保存即可。接下来可以使用PHP7的新特性来升级网站了。


CodeBye 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权 , 转载请注明PhpStorm 中配置修改 PHP 语言版本为7.3
喜欢 (0)
[1034331897@qq.com]
分享 (0)
发表我的评论
取消评论

表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址