Android版本的问题

移动开发 码拜 4年前 (2016-09-14) 437次浏览
今天做了个功能,然后朋友帮本人解决了;这让本人很费解android版本的关系。android运行在6。0以下手机和6。0手机上创建文件夹;在 <uses-sdk   android:minSdkVersion=”14″   android:targetSdkVersion=”22″ /> android:targetSdkVersion=22的时候6.0创建没有问题,可是当android:targetSdkVersion=23的时候程序会奔溃 查了以下没有创建成功;所以现在很混乱  我们android编译选择的sdk版本和运行时候的版本还有这个android:targetSdkVersion 到底是个什么关系
解决方案

100

Android6.0系统默认为targetSdkVersion小于23的应用默认授予了所申请的全部权限,所以假如你以前的APP设置的targetSdkVersion低于23,在运行时也不会崩溃

CodeBye 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权 , 转载请注明Android版本的问题
喜欢 (0)
[1034331897@qq.com]
分享 (0)