SlidingMenu和appcompat_v7之间的冲突

Android 码拜 5年前 (2015-04-26) 185次浏览 0个评论

更准确地来说是,SlidingMenu的依赖库ActionBarSherlock和appcompat_v7之间的冲突。

1、因为我的MinSDK是2.3 ,所以在创建工程的时候,ide会自动给我加上appcompat_v7这个包。
2、在使用SlidingMenu时,必须要导入ActionBarSherlock

问题是现在ActionBarSherlock和appcompat_v7之间发生了冲突。
ide报的错是:attrs.xml的元素重复定义。
上传一张截图:
SlidingMenu和appcompat_v7之间的冲突
不知道遇到这样的问题,大家是如何解决的。

SlidingMenu和appcompat_v7之间的冲突
20分
你需要用appcompat吗,不需要就删掉啊
SlidingMenu和appcompat_v7之间的冲突
引用 1 楼 wlianghe00 的回复:

你需要用appcompat吗,不需要就删掉啊

当然要用。
我问的就是有在appcompat存在的情况下,遇到这种情况怎么处理。

SlidingMenu和appcompat_v7之间的冲突
楼主  我遇到和你同样的问题   怎么解决啊

CodeBye 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权 , 转载请注明SlidingMenu和appcompat_v7之间的冲突
喜欢 (0)
[1034331897@qq.com]
分享 (0)

文章评论已关闭!