地图API和androidSDK版本高了和低版本有没有冲突

移动开发 码拜 5年前 (2015-04-24) 175次浏览 0个评论

我现在的地图API和androidSDK版本都是最新的,朋友有一个2012年编写的安卓定位,导航,热点搜索软件,安卓2.2的,整个工程包,我现在还可以导入到我的elcipse,在模拟器上运行吗,还有那个key,导入到我的elcipse上,需要更改吗

地图API和androidSDK版本高了和低版本有没有冲突
5分
这个要看情况……
例如2.2可能耗时操作还在ui线程放着呢。4.X以上肯定要报错
还有key的话是不是用包名加签名的md5生成?你换了项目这些是不是都变了?
等等……
可以试一试,如果不行就别花精力修改了,除非代码写的很简洁容易维护。
地图API和androidSDK版本高了和低版本有没有冲突
引用 1 楼 inquisitive_plus 的回复:

这个要看情况……
例如2.2可能耗时操作还在ui线程放着呢。4.X以上肯定要报错
还有key的话是不是用包名加签名的md5生成?你换了项目这些是不是都变了?
等等……
可以试一试,如果不行就别花精力修改了,除非代码写的很简洁容易维护。

他是准备整个工程包给我,我直接导入,不用新建一个工程复制代码,模拟器到时可以弄低版本的,就是我现在的sdk和地图API都是新的,我现在就是怕新旧地图API有些类和方法都不一样,还有key得问题,在2012年的他的机子上是可以运行的,其实他整个工程包应该是导入的旧的地图API的jar包,只要我不换了,应该都是行的吧,key的话,换个机子调试都要不一样吗

地图API和androidSDK版本高了和低版本有没有冲突
引用 2 楼 u010413585 的回复:

他是准备整个工程包给我,我直接导入,不用新建一个工程复制代码,模拟器到时可以弄低版本的,就是我现在的sdk和地图API都是新的,我现在就是怕新旧地图API有些类和方法都不一样,还有key得问题,在2012年的他的机子上是可以运行的,其实他整个工程包应该是导入的旧的地图API的jar包,只要我不换了,应该都是行的吧,key的话,换个机子调试都要不一样吗

key的话,例如百度的是签名的md5+包名合成的
包名一样,但是你签名md5可能不一样,你要检查一下。换机子换了eclipse可能不一样

地图API和androidSDK版本高了和低版本有没有冲突
引用 3 楼 inquisitive_plus 的回复:
Quote: 引用 2 楼 u010413585 的回复:

他是准备整个工程包给我,我直接导入,不用新建一个工程复制代码,模拟器到时可以弄低版本的,就是我现在的sdk和地图API都是新的,我现在就是怕新旧地图API有些类和方法都不一样,还有key得问题,在2012年的他的机子上是可以运行的,其实他整个工程包应该是导入的旧的地图API的jar包,只要我不换了,应该都是行的吧,key的话,换个机子调试都要不一样吗

key的话,例如百度的是签名的md5+包名合成的
包名一样,但是你签名md5可能不一样,你要检查一下。换机子换了eclipse可能不一样

那我把我的key输进去可以运行吗?他的工程包导入我的eclipse,他的可能是旧版的百度地图API,也可以用吗?还有百度地图API的key是那个AK下面的那些字母吗?

地图API和androidSDK版本高了和低版本有没有冲突
15分
嗯,百度地图的key是一堆字母
至于能不能用就不清楚了,百度地图3.0的api改动很大,不知道它还支持了旧版本的不。
需要你跑一下程序
地图API和androidSDK版本高了和低版本有没有冲突
引用 5 楼 inquisitive_plus 的回复:

嗯,百度地图的key是一堆字母
至于能不能用就不清楚了,百度地图3.0的api改动很大,不知道它还支持了旧版本的不。
需要你跑一下程序

导入了,没有出现红灯泡错误,但是运行时出现The application has stopped unexpectedly,
详细见http://bbs.csdn.net/topics/391015763?page=1#post-399090168


CodeBye 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权 , 转载请注明地图API和androidSDK版本高了和低版本有没有冲突
喜欢 (0)
[1034331897@qq.com]
分享 (0)

文章评论已关闭!