如何为多个版本的IPHONE编译应用程序?

iOS 码拜 7年前 (2015-05-07) 344次浏览 0个评论
 

现在的问题是我用IOS SDK 4.3 编译打包我的程序,在另外一台手机上运行不了,因为他的是系统4.1。我想编译打包4.1版本,但是mac上只有sdk4.3。
我想问是不是我需要安装一个4.1SDK才行?

理论上是这样的。你可以看看4.3是否支持向下兼容,有没有选项之类的支持为4.1的编译
Project Build setting 里面设置iOS Deployment Target 为对应版本
如果是测试版本,证书是否添加了设备id?
40分
高版本的SDK是不可以在低版本的设备上运行的。你可以将你的project的target改成ios4.1版本,然后运行,把不能支持的API修改掉。
顶楼上的!

CodeBye 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权 , 转载请注明如何为多个版本的IPHONE编译应用程序?
喜欢 (0)
[1034331897@qq.com]
分享 (0)

文章评论已关闭!