坑爹的Android Studio JDK1.7配置

Android 码拜 6年前 (2015-07-18) 552次浏览

各路大侠, 本人刚刚安装了android studio。满心欢喜的配置好了一切工作,最后编译程序下载到手机的时候提示如下:

Error:(54, 61) 错误: -source 1.6 中不支持 diamond 运算符
(请使用 -source 7 或更高版本以启用 diamond 运算符)

可以是明明用的JDK1.7啊,以前在Eclipse里面一直没有问题。我看了一下other setiings -> default project struct里面的JDK也是1.7啊。  在命令行输入javac – version 也是输出java1.7 。

实在不知道怎么设置,我压根没安装过jdk1.6,请问各位用android studio的大侠这个要怎么搞?

谢谢了!

#1

怎么没人呢?  是不是都不用Android studio  都在用Eclipse吗?

#2

在线等。     不会真没人用吧。
10分

#3

Android studio 我电脑都带不起来,用的内存实在太多了。

#4

回复3楼:

额,但是好像都说用起来不错~~  所以想体验一下

#5

好吧。
我已经解决了。   继续用studio吧~
10分

#6

回复4楼:

我还是用的eclipse 拿东西电脑实在带不起来。

#7

遇到同样的问题了,求问lz最后怎么解决的,万分感谢!

#8

求答案我也遇到这个问题了

CodeBye 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权 , 转载请注明坑爹的Android Studio JDK1.7配置
喜欢 (0)
[1034331897@qq.com]
分享 (0)