运行android项目时出现这个问题,求指导

移动开发 码拜 4年前 (2016-09-24) 422次浏览
Errors occurred during the build.
Errors running builder “Android Package Builder” on project “helloworld”.
com/android/dx/command/dexer/Main : Unsupported major.minor version 52.0
解决方案

14

version 52.0的错误是指原先项目是jdk8编译,却运行在jdk7上。只要将项目编译和运行的jdk版本保持一致即可

1

myeclipse不能1.8compiler

1

Properties下的Java compiler和Java build path保持一致即可,1.7或1.8

2

本人今天也遇到这问题了,最后解决办法是:
1、安装JDK1.8;
2、干脆不要选择指定哪个版本的JDK,原因是无论你选1.6、1.7还是1.8都报错,把那页全部勾全去掉,让他本人决定,就没事了。
最后:本人大半年没做安卓了,临时先能用再说。准备弃用Eclipse了,还是谷歌本人的东西匹配好一些。

2

不是版本低的问题是版本不一致的问题,eclipse中的preferences-java-installed jres和preferences-java-compiler和安卓项目的properties-java compiler和java version和javac version的版本都要一致,就可以了,一般情况下,安卓下面的properties下的java compiler的版本不容易注意到

CodeBye 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权 , 转载请注明运行android项目时出现这个问题,求指导
喜欢 (0)
[1034331897@qq.com]
分享 (0)