使用了ios5的类,可以在低于ios5的设备上运行吗

iOS 码拜 9年前 (2015-05-05) 287次浏览 0个评论
 

1。 使用了NSJSONSerialization,指定deployment target 为4.3 ,模拟器运行没问题

2。 使用了storyboard,指定deployment target 为4.3 ,xcode的错误提示:Storyboards are unavailable on iOS 4.3 and prior.

使用了ios5的类,可以在低于ios5的设备上运行吗
没问题,就看你怎么用

加一个版本区分,把 NS_AVAILABLE(10_7, 5_0)标记的函数分出来就是啊

使用了ios5的类,可以在低于ios5的设备上运行吗
20分
不行,你低于ios5设备的系统里都没有storyboard的支持,当然用不了,除非加以区分,低于ios5的另写一套以达到兼容
使用了ios5的类,可以在低于ios5的设备上运行吗
20分
NSJSONSerialization
这个在低版本的设备上肯定是不行的,storyboard我就不清楚了

CodeBye 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权 , 转载请注明使用了ios5的类,可以在低于ios5的设备上运行吗
喜欢 (0)
[1034331897@qq.com]
分享 (0)

文章评论已关闭!